Michaqel's game! Beyond Earth 2 (e0fb91ba)

Smack talk goes here for Michaqel’s game! Beyond Earth 2! Game URL: https://playyourdamnturn.com/game/e0fb91ba-61e0-43c9-aed1-c4dce8b5a863

Hi Guys,
I created another game: https://www.playyourdamnturn.com/game/05ebc6c2-b51d-40c2-b038-abdefbf6318f

Map is existing Earth like planet Kepler 186f.

If you want play we have still place for you.


I’m getting an ‘Unhandled exception error’ when I hit next turn on this latest turn – anyone had this issue on Beyond Earth before? Have tried playing the turn differently, but no effect. Am inclined to try reverting the turn next, unless anyone has a better idea …

Other game is working. It seems the problem is on the file. Try revert it back to Birddog.

1 Like

Still having same problem, next thing I can think of is to set myself to vacation and let the AI do my turn :frowning: and maybe it won’t recur?

or surrender I guess, seems if I set myself to vacation it’ll interfere with some of my other games as well

And tried revert your turn?

I tried it revert to Kanibalhamster, maybe it can help. Sorry for repeating your turn guys.


I tried the single revert before my last comment, sorry for being unclear – fingers crossed the multiple revert avoids it, thanks!

unfortunately the multiple revert didn’t avoid the issue, here’s the error report if anyone recognizes the error:
Unhandled Exception
Error reading address 0x2

Call Stack

(0x000000002E7D0000 : 0x001BD5C0) CvGameCoreDLL_Expansion1FinalRe ! lua_toboolean (???, line 0)
(0x000000002E7D0000 : 0x002434F0) CvGameCoreDLL_Expansion1FinalRe ! HksCompilerSettings::getStrip (???, line 0)
(0x000000002E7D0000 : 0x00243567) CvGameCoreDLL_Expansion1FinalRe ! HksCompilerSettings::getStrip (???, line 0)
(0x000000002E7D0000 : 0x0019FAA6) CvGameCoreDLL_Expansion1FinalRe ! lua_toboolean (???, line 0)
(0x000000002E7D0000 : 0x001AC422) CvGameCoreDLL_Expansion1FinalRe ! lua_toboolean (???, line 0)
(0x000000002E7D0000 : 0x000F6E6C) CvGameCoreDLL_Expansion1FinalRe ! HksCompilerSettings::getIntLiteralsEnabled (???, line 0)
(0x000000002E7D0000 : 0x000F2F93) CvGameCoreDLL_Expansion1FinalRe ! HksCompilerSettings::getIntLiteralsEnabled (???, line 0)
(0x000000002E7D0000 : 0x00102F87) CvGameCoreDLL_Expansion1FinalRe ! HksCompilerSettings::setBytecodeSharingFormat (???, line 0)
(0x000000002E7D0000 : 0x000D2329) CvGameCoreDLL_Expansion1FinalRe ! HksCompilerSettings::getIntLiteralsEnabled (???, line 0)
(0x0000000000400000 : 0x002B5AA5) civilizationbe_dx11 ! ForgeUI::ControlBase::SetConsumeMouseButton (???, line 0)
(0x0000000000400000 : 0x00559293) civilizationbe_dx11 ! PeekLogFileMgr (???, line 0)
(0x0000000000000000 : 0x768000C9) ??? ! ??? (???, line 0)
(0x0000000000000000 : 0x77597B4E) ??? ! ??? (???, line 0)
(0x0000000000000000 : 0x77597B1E) ??? ! ??? (???, line 0)

I’ve done a full uninstall/reinstall of beyond earth, and the game file still gives the same exception access violation and crashes beyond earth when I hit next turn. This game file is the only one that gives it … at this point, within pydt, I think the only remaining options are either to revert a full round of turns or for me to surrender, am open to any other ideas

Can you write this exception on discord and try discuss it with Valamas? Maybe somebody know what can be problem and yes maybe somebody say: “Yes, you have to revert whole round.” It is no problem do it.

Have posted on discord, no specific actionable suggestions yet (other than a suggestion that file bloat may be the problem). I’ve checked to see if the unbloat mod is loadable for beyond earth, and it’s not present in the beyond earth workshop. Could we revert a full round of turns and see if that avoids the issue?

Yes of course, I am going to do it.

It is on you one round back. Try if is possible load it, if not, then I revert one turn more.


Maybe the save file got corrupted?

that seems to have been the case somehow … fingers crossed a full round of redos doesn’t suffer the same problem :hand_with_index_finger_and_thumb_crossed:

1 Like

ugh, getting the same error when I hit next turn. Since this is the only game it’s my turn, I’m going to turn on vacation mode so I get skipped in this game, and will see if the problem recurs for me on the next round and/or happens for any of you … :hand_with_index_finger_and_thumb_crossed: it doesn’t

1 Like

@Michaqel could you add a timer, just so I can get myself skipped here? can remove it after I’m skipped