Unhandled exception error

Hello! I have a player in my Banman39’s Archipelago FFA! (7!8a63abc) game reporting the following error:

"Getting an error message when I load up:

Unhandled Exception
Error reading address 0x48

Click ok crashes to desktop, tried 3 times. I’ll try revert."

He told me the game crashes out when he clicks OK on the error window, but he is able to move the error window and sees that it’s the correct game, and that it appears the turn is not completely processing (his units still have the movement points they had at the end of his last turn, production hasn’t progressed, etc.). We’ve reverted once (I’m the human player right before him, there’s an AI position – eliminated civ – between us), with the same result. The eliminated civ was knocked out quite awhile ago, not newly happened. Any ideas of what we can do to remedy the situation?


Did you ever get past this?

Not the OP, but we have a similar situation in our game right now (Postdocs and Riffraff 2: Electric Boogaloo). Player 4 is experiencing the same EXCEPTION_ACCESS_VIOLATION on address 0x48. Player 5 (AI) and Player 6 (AI) have been eliminated, player 7 (AI) remains.

The crash is happening at the end of Player 4’s turn, as the AI is processing the turn. Player 2 can access the Player 4 round 109 save on his computer and has the same error; the problem appears to be tied to the save, not the installation. Player 4 has done a complete reinstall and experiences the same problem with a vanilla installation. We have reverted the game back two full rounds and experience the crash on the same turn (end of round 109) after replaying the rounds again.

Players 1 and 2 have taken earlier saves from the archive (e.g, 103, 105) and, when playing the save through in single player, can both get past turn 109 with no issues; so we’re a little befuddled as to what exactly might be going on.

Any suggestions would be appreciated, and happy to provide any additional information.

Sadly no … we ended up abandoning the game and starting a new one. The unhandled exception error initially popped up on a player following a defeated AI position, and occurred after he loaded the turn but before it finished processing actions. The error would recur on that turn for that player, regardless of how much we reverted, and if we skipped the player, the following player would have the same error. Couldn’t figure out any way around it :frowning:

Sounds very similar to what we faced, and we tried the same types of remedies with similar results :frowning: if you can figure a way around, would love to hear of it! nothing we tried worked, it definitely seemed to us to be a problem that had developed with the save file as well (same error would come up on other civ6 installations from the same turnfile)