Medieval Europe - v3.0 (9356905f)

Smack talk goes here for Medieval Europe - v3.0! Game URL:

Is he back from vacation?

I’ve opened a thread looking for a substitution for him. Looks like he’s not coming back. I’ll also post a sub request on the discord forums.

1 Like

If you need a sub…

hi are you interested in joining our game?

Sure, if you need help.

I’ve DM’d you :slightly_smiling_face: :+1:

i can’t play my turn it says a mod is interfering but when i turn them all off it also doesn’t work

the problem is due to an update of DB’s mod. You need to install an older version and disable the newest version

Check the discord for a link to full instructions

i have tried the fix and still no luck.

Per DB from Steam:

Thanks for the excellent bug report. So Remove Government Plaza is conflicting with Better Government Plaza, and the BGP option is also bugged because when you un-check it (in the game settings menu) it’s still active.

I’ll fix all this in my next update. Meanwhile, here’s how to get by:

  1. close out of civ 6

  2. open \workshop\content\289070\2533573440\DB - Civ 6 Multiplayer Gold.modinfo in a text editor (like Notepad)

  3. Search for
    and replace it with
    (two occurrences: lines 1496 and 1504… this makes it so that BGP is tied to its checkbox)

  4. Next search for
    which should take you to line 2015. Two lines later (line 2017), update the LoadOrder number from 999990 to 999992 and do the same for RemoveGovernmentPlazas_Text (line 2024). These edits make it so that RGP loads after BGP (thus overriding it if both are selected).

Kind regards,

1 Like

superb thanks

Yeah he prob just did the fix wrong, cuz it worked fine for me. Anyway, what is actually happening with this game? lol it’s been like months, we’ve played how many turns? I still haven’t met anyone on the map lol. Are we still playing this game?

multiple players have been having issues with loading the game because of the update to DB’s mod causing it to crash

This has affected 3 of the games that I’m playing. I don’t know how long it will take to iron it out - it may just be that we have to stick it out until DB’s next update fixes the problem

1 Like

that fix looks doable if you can pass me the turn

Looks like I’m stuck at the moment too

Yeah I had that and managed to sort it using the work round that @dand4444 posted above.

1 Like

Yeah… people are just incompetent and aren’t following directions… this is pretty frustrating I don’t really want to play this game anymore.

I fixed it, we’re just waiting for @andrewsmart48 now

I managed to play. Really sorry for the delay I am really busy just now and even small hurdles are setting me back.

1 Like