[FIXED] Client not downloading save files after update

After updating this morning, the client no longer downloads the save file for me. It just goes blank after I press the play your turn button. I was able to download and play the save file from the webpage. I’m running Windows 10 Pro.

Was this a one time thing, or is it still happening? Can you go to Debug/Toggle Developer Tools, and take a screenshot of the Console tab? Thanks!

So far it’s only happened once, but the game has not made it’s way back to me yet. One of our players is in vacation, so it’s going to be a week or so before it’s my turn again. I did restart the app, and restarted my computer, with no change. I’ve attached the screenshot you requested, and another that shows what happened when I tried to download the game.


p.s. Thanks for the quick response. Didn’t expect a response on Easter. Kudos!

Yesterday my laptop decided not to download games anymore. I was traveling but it has not worked at home either. I have another desk system that works still. I checked the firewall and put an exception to make sure that it had not done anything. It shows the game but does not download it. Running Win10. Any ideas?

I’m pretty stumped as to what the issue could be, nothing seems to be erroring in that screenshot. If you could also make a screenshot, @dand4444, that’d be great.

Thanks, @dand4444. Since there’s “OneDrive” in that path, I think the error might be related to that. I’ve had other users in the past report issues if the PYDT client was trying to save to OneDrive, see this thread: https://github.com/pydt/client/issues/12.

We didn’t really get any resolution there, but it sound like there might be some fixes in newer versions of electron, so I’m going to beef up the error handling, upgrade the dependencies, and release a new version in the next couple of days. I’m not sure if that will solve your problem, though. :frowning:

Thanks for trying. I appreciate it. Gives me something to try regardless.

FWIW, my saves are also going to One Drive. My “Documents” folder is located there. So that may be a common thread between our 2 problems.


I’ve had the same issue as well. Eagerly awaiting a new version, for now I’ve stuck to manually downloading and uploading saves but that is hella tedious.

Sorry, I probably won’t get a release out until the weekend, but have any of you changed anything recently with regards to onedrive? Are your my documents synced to onedrive? It’s a crapshoot if the changes I have now will fix the bug, and I doubt I’ll be able to really fix this unless I can duplicate it. Thanks!

I was able to duplicate this with OneDrive - when OneDrive is in “Files On-Demand” mode, the client has trouble reading and writing to the directory. I wasn’t able to find a workaround, so I’ve added a message that will inform users to disable that mode. This should be “fixed” in 1.2.5.

I tried this. Had not remembered files on demand setting. I changed it and I still got the warning and not able to save. I tried rebooting but the same result. Not sure what else to do with that. Thanks for working on it.

Did your PC have time to download all the files from your OneDrive? I was able to replicate the error pretty consistently on my PC, sorry it isn’t working for you. :frowning:

That is what it said. I will try again after more time but I was looking for that.

Yes, it still fails. Is there a manual work around? I suppose we could just email files but the service is nice. I am ok for now but when I travel it will be a problem.

You can just use the website to submit your turn.

Changing the OneDrive setting did work for me. The client downloaded the file, and started Civ6 as expected.