[DONE] Question about players joining game after start

I created a game here to test using a mod to run a bunch of AI controlled turns before having human players jump in: https://www.playyourdamnturn.com/game/7dd508d4-b503-4ff7-951e-2aba035b4952

I had one other person join, then I generated the game and ran it for 10 turns in single player, then saved the game again in hotseat and used the ‘reset game state’ option to overwrite it. It looks like the two of us that initially joined before the game started are able to continue playing. However, it looks like other players are unable to join the game at this point through PYDT.

Did I break something with the game, or is this a situation where an administrator would have to replace the AI players?

If you’re asking about why it’s not showing on the in progress games with open slots tab, I filter out password protected games on that list. Are you saying that people can’t join it at all?

Yes, some players tried to join and they got errors saying the slots weren’t available. I didn’t try making another Steam account to test joining it myself, but if it helps I can try that to see exactly what happens.

OK, that’s weird, could definitely be a bug, what’s the password?

should be “papatestgame”

OK, I think the bug should be fixed, it was because of the all random, give it another shot.

Sorry, i didn’t test the fix and it looks like someone tried it and it didn’t work, I think it’s good now :crossed_fingers:

Ha, thanks, I’ll have them try again. This is what they were seeing: https://cdn.discordapp.com/attachments/1135010570001731644/1151210797905760347/image.png